[Vita] Quelques infos sur l’éventualité d’un HENkaku compatible avec les 3.65, 3.67 et 3.68

Cela fait maintenant près de 2 années que HENkaku, le premier HEN pour PS Vita, est sorti, et près d’un an que sa version permanente HENkaku Ensō a été partagé. Grâce à ces programmes, la scène underground de la PS Vita a enfin pu décoller forte de l’apparition de nombreux homebrews, plugins, thèmes et outils. Mais il y a malheureusement une contrainte qui empêche encore aujourd’hui un grand nombre de joueurs de profiter de tout ceci, c’est la compatibilité unique avec la version 3.60 du firmware, à cause de la correction de la faille exploitée dans les versions ultérieures.

Cependant, il se pourrait que les choses évoluent…

HENkaku, le premier Homebrew ENabler pour PS Vita de la team Molecule
Montage par @Windvern


Commençons par une petite piqûre de rappel, pour ceux qui l’auraient oublié ou qui ne sont pas au courant. Plus tôt dans l’année, le célèbre développeur TheFloW mentionnait sur son compte Twitter qu’il était parvenu à exécuter HENkaku sur sa PS Vita en 3.65 ainsi qu’en 3.67. Quelques semaines plus tard, il mettait en ligne un installateur pour les consoles hackées en 3.60 permettant de mettre à jour vers la version 3.65 tout en gardant son Custom Firmware Ensō. Puis enfin, lorsque Sony sortit sans crier gare la version 3.68, TheFloW rassura les internautes en communiquant qu’elle ne patchait pas la vulnérabilité qu’il utilisait.

Aujourd’hui, que retenir de toutes ces informations ? Peut-on espérer une éventuelle release d’un hack exécutable depuis une console équipée d’une version du firmware supérieure à 3.60 ? La réponse est (sûrement) « oui » !

TheFloW vient effectivement de clarifier un peu la situation en informant sur Twitter qu’il travaillait sur un jailbreak compatible avec les versions 3.65, 3.67 et 3.68 (la dernière à ce jour) du système. Il a également livré quelques conseils à ses followers que voici :

  • Si la version de votre PS Vita est la 3.61 ou la 3.63, mettez à jour vers la 3.65 ;
  • Si la version de votre PS Vita est la 3.67, mettez à jour en 3.68.

À ces conseils, nous pouvons rajouter que :

  • Si la version de votre PS Vita est inférieure strictement à 3.60, vous pouvez mettre à jour vers la 3.60 ;
  • Si la version de votre PS Vita est égale à 3.60, ne touchez à rien pour le moment ;
  • Si la version de votre PS Vita est la 3.65, ne touchez à rien non plus.

Finalement, TheFloW a également révélé que seule la version 3.65 pourrait bénéficier du Custom Firmware, c’est-à-dire de HENkaku de façon permanente, Sony ayant patché l’exploit se situant au niveau du bootloader (démarrage) avec la 3.67.

Oh et, j’allais presque oublié la date de sortie de tout ceci ! Eh bien, elle n’a pas encore été fixée, mais il semblerait que l’on puisse s’attendre à une release d’ici la fin de cette année 2018 ou bien en 2019…

Mise à jour : TheFloW a indiqué qu’il ne sortirait rien avant septembre 2018 (merci à @Cimmerian pour l’information).


Bien sûr, même si TheFloW vient de nous livrer tous ces conseils et qu’il n’est pas connu pour garder ses travaux pour lui-même, nous ne pouvons garantir à 100 % qu’il y aura bien une sortie publique : cela seul l’avenir nous le dira… Et rappelez-vous que la patience est mère de toutes les vertus ! 🙂