Custom Protocol

[PS4] Exploit Webkit fonctionnel sur les firmwares 2.XX ?

Le développeur Fire30 aurait fourni un PoC d'un portage de l'exploit webkit de Liang Chen (datant de 2014) fonctionnant sous le firmware 2.03.

Cet article fut écrit sur la base de l'article de Wololo, merci à lui.

Wololo l'a annoncé hier soir, le développeur Fire30 aurait fourni un proof of concept (une preuve de concept) d'un portage de l'exploit webkit de Liang Chen (datant de 2014), fonctionnant pour la démonstration sur une PlayStation 4 sous firmware 2.03.

ps4 fond bleu joli joli hack tete de mort skull


Le développeur aura déclaré en passant que sa réécriture de l'exploit devrait fonctionner avec tous les firmwares de 2.00 à 2.50, tout en rappelant qu'une partie de son code tel qu'il est actuellement ne devrait fonctionner que sous 2.03. C'est en effet le firmware qui a été utilisé durant l'écriture de son code. 

De là à imaginer un portage de l'exploit dlclose, permettant le jailbreak de la console et le portage de Linux tel que nous l'avons actuellement en 1.76, il n'y a évidemment qu'un pas. Au rythme où vont les choses, nous pouvons donc être très optimistes quant à l'avenir du hack de la PlayStation 4 ! 😀

Si vous pensez avoir les compétences nécessaires, vous pouvez bien évidemment télécharger le proof of concept sur le GitHub de Fire30. Il vous faudra donc être en 2.50, et de préférence en 2.03.

Si jamais vous arrivez à le faire fonctionner, n'hésitez pas à nous le signaler dans les commentaires ! 😀

Crédits de l'exploit : Fire30, Liang Chen, thexyz, dreadlyei

0 commentaire


Laisser un commentaire

           
Covid-19 bannière

Suivez-nous

Venez, on n'est pas méchants, on est même très sympas ! 🙂

Sujets récents du forum

Catégories

Archives

Covid-19 bannière
Bannière Hypsoma
Covid-19 bannière

Suivez-nous

Venez, on n'est pas méchants, on est même très sympas ! 🙂

Catégories

Archives